Level Editor crash?

Help using the built in level editor to create your own levels

Level Editor crash?

Postby coz » Wed Apr 18, 2012 2:44 pm

HI me again with another problem! :oops: lol

On level editor every thing is good, but when I create a level or part of a level. Then when i save and then exit i get a crash to desk top and i'm unable to load back my level, when I restart my game.
This also happens when i play test my level too.

But it won't crash if I do this on a pre made level, I can make changers and play test the level fine.

Any help would be appreciated.
User avatar
coz
Clones Newbie
 
Posts: 6
Joined: Thu Mar 29, 2012 6:33 am

Re: Level Editor crash?

Postby rt » Wed Apr 18, 2012 5:00 pm

I tried creating a new level in the editor and was able to play test it without any problem.

Please provide the steps you take that will produce the crash, starting with:
Step 1: Start Clones, click Extras->Level Editor->New

If we can reproduce the problem then we can fix it! :)
User avatar
rt
Developer
 
Posts: 564
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Level Editor crash?

Postby coz » Thu Apr 19, 2012 4:09 am

I found what is causing the problem.

When i delete the default start & put a new start position in then save my level it crashers, then when i come to load the game there is no start position on the picture where you load the game.

Also when i put the new start position in and change the value how many clones come out. The start position turns into a red cross with a yellow background.
If I save it when the cross is on and exit, then try to enter the level editor again it crashers to desktop. So i have to delete the level in the clones folder in my documents to get back into the level editor.

Hope this helps.
User avatar
coz
Clones Newbie
 
Posts: 6
Joined: Thu Mar 29, 2012 6:33 am

Re: Level Editor crash?

Postby rt » Fri Apr 20, 2012 10:19 am

I've experienced this as well. A patched Steam version will be released to correct it soon, thanks!
User avatar
rt
Developer
 
Posts: 564
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Level Editor crash?

Postby rt » Mon Apr 23, 2012 12:19 pm

A work around for the crash when adding a new Start trap object is to set the group color. Currently a new Start trap is incorrectly defaulting to "any group" (white clone head outline) which is not supported. Click on that to set the group to one of the 8 colors and the level should load up fine.
User avatar
rt
Developer
 
Posts: 564
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Level Editor crash?

Postby rt » Thu Apr 26, 2012 1:14 pm

This should be fixed in the current Steam version.
User avatar
rt
Developer
 
Posts: 564
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada


Return to Level Editor Help

Who is online

Users browsing this forum: No registered users and 4 guests

cron