Bug & Stuck

General Clones Discussion

Bug & Stuck

Postby Valorin » Mon Apr 02, 2012 11:21 am

I'm stuck in the sixths puzzle of the Robobrain clonemaster... I activated the switch that blew up the wall but my clone is still not able to move along. Zooming in revealed three little "dots" that seem to be leftovers of the wall.
After some retries I used the Solution-Button, but that didn't work either.
I also tried restarting the game, changing profile and even changed the resolution... Didn't work.
I have the Steam-Version of the Game.

Can anybody help me out?
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby rt » Mon Apr 02, 2012 1:12 pm

The 6th RoboBrain level is "Last Lopper".

I've tried this level in v1.32 and the wall cleanly blew apart for me. Here are screenshots before and after hitting the switch.

clones_screenshot_0000.jpg
before
clones_screenshot_0000.jpg (287.31 KiB) Viewed 8056 times


clones_screenshot_0001.jpg
after
clones_screenshot_0001.jpg (272.88 KiB) Viewed 8056 times


Can you post some screenshots, or perhaps a video so that we can see the problem?

Also, please post the contents of your Client.txt and Server.txt:
(Windows 7) C:\Users\<username>\AppData\Roaming\Clones\Cache\Log\
(Windows XP) C:\Documents and Settings\<username>\Application Data\Clones\Cache\Log\

One way to get around this is to use the "Unlock All Puzzles" checkbox in the Options Menu from the Main Menu. Then you can play the next puzzle and once you solve it you can uncheck the option and continue forward.
User avatar
rt
Developer
 
Posts: 565
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Bug & Stuck

Postby Valorin » Mon Apr 02, 2012 1:45 pm

Thanks for your very fast reply.
Here's a screenshot:
Clones Bug.JPG
Clones Bug.JPG (93.06 KiB) Viewed 8052 times



Client Log:

Game Version=132, Product Id=4
Path set 47
Couldn't read window position..using defaults
Adding Resource: Data\resource.dat
Adding Resource: Data\resource01.dat
Resource loaded 187
Resource indexed 281
loading paramfile.. 281
Steam Cloud: NC C:\DOKUME~1\Noah\EIGENE~1\Clones\profiles\timo.xml [profiles/timo.xml]
Steam Cloud: NC C:\DOKUME~1\Noah\ANWEND~1\Clones\cache\settings\global_config.xml [cache/settings/global_config.xml]
Steam Cloud: NC C:\DOKUME~1\Noah\ANWEND~1\Clones\cache\settings\complete.cfg [cache/settings/complete.cfg]
Steam Cloud: NC C:\DOKUME~1\Noah\EIGENE~1\Clones\profiles\ich.xml [profiles/ich.xml]
Steam Cloud: NC C:\DOKUME~1\Noah\EIGENE~1\Clones\profiles\test.xml [profiles/test.xml]
loading graphics.. 469
d3d is hard and hal
loading fonts.. 703
loading cursors.. 703
loading language.. 703
loading sound.. 703
loading player profile.. 984
loading console.. 984
loading keyboard.. 984
loading mouse.. 1000
Found a mouse [Maus] : Maus
loading network.. 1000
loading controller.. 1000
loading landscape.. 1000
loading clones.. 1000
loading traps.. 1015
loading cursors.. 1031
loading particles.. 1031
loading keybindings.. 1031
Loading profile [Timo]
Set FullScreen Mode
Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
loading items.. 2219
all initialization complete..
Game ready 2390
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Failed to open download local file Ads\demo-ad-01.jpg
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
PlanetScene ok
Worldmap loaded
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
LevelManager.. refreshed 4109
Created preview for s_dm_just-drill-tulf9 in 2895 ms
Du musst zuerst einen Levelnamen eingeben.NEW CONNECTION DETECTED. Client = 0


Server Log:

Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 152 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 155 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 150 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 148 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 162 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 159 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
NEW CONNECTION DETECTED. Client = 0
Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Testlevel loaded in 166 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
ClonesGameBase::Dispose
Couldn't create landscape vertex bufferERROR: landscape vertex bufferGameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
LevelManager.. refreshed 15
Created preview for s_dm_testlevel-z9nwo in 670 ms
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Destroying Window....
Set Windowed Mode
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Steam Destroy....
xmlCleanupParser....
fileManager....
FM1
FM2
FM3
FM4
CoUninitialize....
protobuf....
[night falls, and once again peace fills the land....]

My Machine:
AMD Athlon 2800
N-Force 2 Board
Geforce 6600 GT 128MB (AGP)
2GB RAM
Win XP Pro
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby rt » Mon Apr 02, 2012 2:01 pm

Your system specs look ok, but the Server.txt contents didn't indicate that you played that "Last Lopper" level. Please do the following to ensure it will contain relevant info:
1) Exit Clones if it's already open.
2) Start Clones
3) Play the "Last Lopper" level and Lop at the switch to explode the wall.
4) Verify that your clone gets stuck on the few random leftover pixels.
5) Exit Clones and then post the contents of Server.txt
User avatar
rt
Developer
 
Posts: 565
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Bug & Stuck

Postby Valorin » Mon Apr 02, 2012 2:17 pm

done:

Reset Server Session (New netload file)
GameInfo has been loaded
CLIENT Timo[0] - Version ok
OnClientGameVersionOk. Client = 0
Last Lopper loaded in 1243 ms
Game Map and Info loaded successfully!
CLIENT Timo[0] - LEVEL LOADED
Requesting Checksum
PlanetScene ok
Worldmap loaded
ClonesGameBase::Dispose
GameServer Destructed
GameClient Destructed!
ClonesGameBase::Destruct
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Destroying Window....
Set Windowed Mode
Saving player profile [Timo]..Saving profile to C:\DOKUME~1\Noah\EIGENE~1\Clones\Profiles\Timo.xml
saved
Steam Destroy....
xmlCleanupParser....
fileManager....
FM1
FM2
FM3
FM4
CoUninitialize....
protobuf....
[night falls, and once again peace fills the land....]
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby Valorin » Mon Apr 02, 2012 2:20 pm

I'm not sure if it is relevant, but the leftovers always look the same. 3 pixels near the ceiling and 3 pixels near the floor where the clone gets stuck.
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby rt » Mon Apr 02, 2012 4:03 pm

Hmm, you Server.txt file looks fine, no warning of texture size problems. Try playing the modified version i've attached and let me know if the same 3 pixels are leftover.

To play:
1) Save the attachment to your My Documents\Clones\Level folder
2) Start Clones and open the level in the editor (Last Lopper Test)
3) Play level (F8)
Attachments
s_lcs_Last-Loppe-JOUTZ.clevel
modified Last Lopper Test
(20.95 KiB) Downloaded 721 times
User avatar
rt
Developer
 
Posts: 565
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Re: Bug & Stuck

Postby Valorin » Mon Apr 02, 2012 4:26 pm

This level works fine.
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby Valorin » Thu Apr 05, 2012 5:08 am

I found a similar problem in the Level "Heart of Clone". The Clones can't pass by the pixels. Theres an easy way to work around that problem but I thought you could be interested in that.

Shot:

clones bug 2.JPG
clones bug 2.JPG (148.59 KiB) Viewed 8008 times
Valorin
Clones Player
 
Posts: 10
Joined: Mon Apr 02, 2012 11:03 am

Re: Bug & Stuck

Postby rt » Thu Apr 05, 2012 11:25 am

Valorin wrote:I found a similar problem in the Level "Heart of Clone". The Clones can't pass by the pixels. Theres an easy way to work around that problem but I thought you could be interested in that.


It seems that for whatever reason your processor/video card combo may be rounding differently than my system and other test systems. If this is true then any level in which the landscape is dynamically modified could produce these artifacts. Using the "Unlock All Puzzles" option would let you progress on levels where this causes a problem but i'd like to know exactly what is causing the problem so that we can fix it.

I'll make an example level that does some land modification which might help narrow down the issue.

Could you try toggling between fullscreen and windowed mode (BACKSLASH is the default hotkey). Try playing the level in one or the other mode, and also with a toggle between them and see if it has any effect. We had an issue in multiplayer before that only happened if one client was fullscreen and the others where windowed.
User avatar
rt
Developer
 
Posts: 565
Joined: Wed Jan 02, 2008 1:32 pm
Location: MB, Canada

Next

Return to Clones Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron